import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)th[^>]+l\">(.*?)<\\/th>.*?<td>(.*?)<\\/td>.*?<a id=\"(.*?)\"";
final String string = "<th scope=\"col\">1X2</th>\n"
+ " <th scope=\"col\" class=\"goR\">Odds</th>\n"
+ " </tr></thead>\n"
+ " <tbody>\n"
+ " <tr class=\"row1\">\n"
+ " <td>Fortuna Köln</td>\n"
+ " <td class=\"prc \"><label><a id=\"MarketGroupListComponent25-selection-38225206.1\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}