#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*):\/\/(.*)(:\d+)\/(.*)$"
Local $sString = "https://uat42.my.example.com:56/Pizza?slice=2"
Local $sSubst = "\1://\2/\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)