$re = '/^(.*):\/\/(.*)(:\d+)\/(.*)$/m';
$str = 'https://uat42.my.example.com:56/Pizza?slice=2';
$subst = "\1://\2/\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;