using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*):\/\/(.*)(:\d+)\/(.*)$";
string substitution = @"\1://\2/\4";
string input = @"https://uat42.my.example.com:56/Pizza?slice=2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}