using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)@\w+";
string input = @"INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES ("" +
""@idRecibo,"" +
""@dataRecibo,"" +
""@nomeCliente,"" +
""@valor,"" +
""@cpfCliente,"" +
""@endCliente,"" +
""@numCliente,"" +
""@baiCliente,"" +
""@importancia,"" +
""@referente, +"" +
""@cidade,"" +
""@uf,"" +
""@emitente,"" +
""@endEmitente,"" +
""@numEmitente,"" +
""@baiEmitente,"" +
""@cpfEmitente,"" +
""@rg)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}