import re
regex = re.compile(r"(?<!\w)@\w+", flags=re.MULTILINE)
test_str = ("INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (\" +\n"
" \"@idRecibo,\" +\n"
" \"@dataRecibo,\" +\n"
" \"@nomeCliente,\" +\n"
" \"@valor,\" +\n"
" \"@cpfCliente,\" +\n"
" \"@endCliente,\" +\n"
" \"@numCliente,\" +\n"
" \"@baiCliente,\" +\n"
" \"@importancia,\" +\n"
" \"@referente, +\" +\n"
" \"@cidade,\" +\n"
" \"@uf,\" +\n"
" \"@emitente,\" +\n"
" \"@endEmitente,\" +\n"
" \"@numEmitente,\" +\n"
" \"@baiEmitente,\" +\n"
" \"@cpfEmitente,\" +\n"
" \"@rg)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")