use strict;
my $str = 'INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (" +
"@idRecibo," +
"@dataRecibo," +
"@nomeCliente," +
"@valor," +
"@cpfCliente," +
"@endCliente," +
"@numCliente," +
"@baiCliente," +
"@importancia," +
"@referente, +" +
"@cidade," +
"@uf," +
"@emitente," +
"@endEmitente," +
"@numEmitente," +
"@baiEmitente," +
"@cpfEmitente," +
"@rg)';
my $regex = qr/(?<!\w)@\w+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}