const regex = /(?<!\w)@\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)@\\w+', 'gm')
const str = `INSERT INTO Recibos (idRecibo, DataRecibo, NomeCliente, Valor, CPFCliente, EnderecoCliente, NumeroCliente, BairroCliente, Importancia, Referente, Cidade, UF, Emitente, EnderecoEmitente, NumeroEmitente, BairroEmitente, CPFEmitente, RG) VALUES (" +
"@idRecibo," +
"@dataRecibo," +
"@nomeCliente," +
"@valor," +
"@cpfCliente," +
"@endCliente," +
"@numCliente," +
"@baiCliente," +
"@importancia," +
"@referente, +" +
"@cidade," +
"@uf," +
"@emitente," +
"@endEmitente," +
"@numEmitente," +
"@baiEmitente," +
"@cpfEmitente," +
"@rg)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}