import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(spark:\\/\\/(?P<host>\\w+.*?):(?P<port>\\w+)|local(\\[([\\d+)|\\*])(,\\s*\\d+)?\\])?)\\s*$";
final String string = "spark://host:1234\n"
+ "spark://host:1234, host:4567\n"
+ "local\n"
+ "local[*]\n"
+ "local[]\n"
+ "local()\n"
+ "local[4]\n"
+ "local[*, 2]\n"
+ "local[4, 2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}