const regex = /(spark:\/\/(?P<host>\w+.*?):(?P<port>\w+)|local(\[([\d+)|\*])(,\s*\d+)?\])?)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(spark:\\\/\\\/(?P<host>\\w+.*?):(?P<port>\\w+)|local(\\[([\\d+)|\\*])(,\\s*\\d+)?\\])?)\\s*$', 'gm')
const str = `spark://host:1234
spark://host:1234, host:4567
local
local[*]
local[]
local()
local[4]
local[*, 2]
local[4, 2]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}