$re = '/(spark:\/\/(?P<host>\w+.*?):(?P<port>\w+)|local(\[([\d+)|\*])(,\s*\d+)?\])?)\s*$/m';
$str = 'spark://host:1234
spark://host:1234, host:4567
local
local[*]
local[]
local()
local[4]
local[*, 2]
local[4, 2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);