// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(spark:\/\/(?P<host>\w+.*?):(?P<port>\w+)|local(\[([\d+)|\*])(,\s*\d+)?\])?)\s*$").unwrap();
let string = "spark://host:1234
spark://host:1234, host:4567
local
local[*]
local[]
local()
local[4]
local[*, 2]
local[4, 2]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}