re = /(spark:\/\/(?P<host>\w+.*?):(?P<port>\w+)|local(\[([\d+)|\*])(,\s*\d+)?\])?)\s*$/m
str = 'spark://host:1234
spark://host:1234, host:4567
local
local[*]
local[]
local()
local[4]
local[*, 2]
local[4, 2]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end