#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z0-9]|(?=[A-Z]))([A-Z])"
Local $sString = "constants.js" & @CRLF & _
"elements.js" & @CRLF & _
"event-listener" & @CRLF & _
"onClickAddProductButton.js" & @CRLF & _
"onClickBackButton.js" & @CRLF & _
"onClickCategoryItem.js" & @CRLF & _
"onClickDeleteButton.js" & @CRLF & _
"onClickFilterByButtons.js" & @CRLF & _
"onClickInstallerCheckbox.js" & @CRLF & _
"onClickNextButton.js" & @CRLF & _
"onClickProductItem.js" & @CRLF & _
"onClickQuantityButtons.js" & @CRLF & _
"onClickRequestNowButton.js" & @CRLF & _
"onClickRestartButton.js" & @CRLF & _
"onClickSubmitButton.js" & @CRLF & _
"onInputProductSearch.js" & @CRLF & _
"onSubmitForm.js" & @CRLF & _
"event-listener.js" & @CRLF & _
"methods" & @CRLF & _
"addProductToCalculationTable.js" & @CRLF & _
"addProductToProductSelection.js" & @CRLF & _
"addProductToStorage.js" & @CRLF & _
"adjustProductQuantity.js" & @CRLF & _
"createProduct.js" & @CRLF & _
"deleteProduct.js" & @CRLF & _
"elementsVisibility.js" & @CRLF & _
"filterVisibility.js" & @CRLF & _
"formatPriceToTwoDecimals.js" & @CRLF & _
"formatProductPrice.js" & @CRLF & _
"getRateTableProductHtml.js" & @CRLF & _
"getSelectedProductHtml.js" & @CRLF & _
"hideAllProducts.js" & @CRLF & _
"hideElement.js" & @CRLF & _
"initCurrentState.js" & @CRLF & _
"initIndicators.js" & @CRLF & _
"initSelectedProducts.js" & @CRLF & _
"initSteps.js" & @CRLF & _
"showAllProducts.js" & @CRLF & _
"showElement.js" & @CRLF & _
"successVisibility.js" & @CRLF & _
"updateCalculationTableProductPrices.js" & @CRLF & _
"updateCalculationTableTotals.js" & @CRLF & _
"updateProductQuantityNumbers.js" & @CRLF & _
"updateSummary.js" & @CRLF & _
"methods.js" & @CRLF & _
"storage.js" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")