use strict;
my $str = 'constants.js
elements.js
event-listener
onClickAddProductButton.js
onClickBackButton.js
onClickCategoryItem.js
onClickDeleteButton.js
onClickFilterByButtons.js
onClickInstallerCheckbox.js
onClickNextButton.js
onClickProductItem.js
onClickQuantityButtons.js
onClickRequestNowButton.js
onClickRestartButton.js
onClickSubmitButton.js
onInputProductSearch.js
onSubmitForm.js
event-listener.js
methods
addProductToCalculationTable.js
addProductToProductSelection.js
addProductToStorage.js
adjustProductQuantity.js
createProduct.js
deleteProduct.js
elementsVisibility.js
filterVisibility.js
formatPriceToTwoDecimals.js
formatProductPrice.js
getRateTableProductHtml.js
getSelectedProductHtml.js
hideAllProducts.js
hideElement.js
initCurrentState.js
initIndicators.js
initSelectedProducts.js
initSteps.js
showAllProducts.js
showElement.js
successVisibility.js
updateCalculationTableProductPrices.js
updateCalculationTableTotals.js
updateProductQuantityNumbers.js
updateSummary.js
methods.js
storage.js
';
my $regex = qr/([a-z0-9]|(?=[A-Z]))([A-Z])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}