# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-z0-9]|(?=[A-Z]))([A-Z])"
test_str = ("constants.js\n"
"elements.js\n"
"event-listener\n"
"onClickAddProductButton.js\n"
"onClickBackButton.js\n"
"onClickCategoryItem.js\n"
"onClickDeleteButton.js\n"
"onClickFilterByButtons.js\n"
"onClickInstallerCheckbox.js\n"
"onClickNextButton.js\n"
"onClickProductItem.js\n"
"onClickQuantityButtons.js\n"
"onClickRequestNowButton.js\n"
"onClickRestartButton.js\n"
"onClickSubmitButton.js\n"
"onInputProductSearch.js\n"
"onSubmitForm.js\n"
"event-listener.js\n"
"methods\n"
"addProductToCalculationTable.js\n"
"addProductToProductSelection.js\n"
"addProductToStorage.js\n"
"adjustProductQuantity.js\n"
"createProduct.js\n"
"deleteProduct.js\n"
"elementsVisibility.js\n"
"filterVisibility.js\n"
"formatPriceToTwoDecimals.js\n"
"formatProductPrice.js\n"
"getRateTableProductHtml.js\n"
"getSelectedProductHtml.js\n"
"hideAllProducts.js\n"
"hideElement.js\n"
"initCurrentState.js\n"
"initIndicators.js\n"
"initSelectedProducts.js\n"
"initSteps.js\n"
"showAllProducts.js\n"
"showElement.js\n"
"successVisibility.js\n"
"updateCalculationTableProductPrices.js\n"
"updateCalculationTableTotals.js\n"
"updateProductQuantityNumbers.js\n"
"updateSummary.js\n"
"methods.js\n"
"storage.js\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.