using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z0-9]|(?=[A-Z]))([A-Z])";
string input = @"constants.js
elements.js
event-listener
onClickAddProductButton.js
onClickBackButton.js
onClickCategoryItem.js
onClickDeleteButton.js
onClickFilterByButtons.js
onClickInstallerCheckbox.js
onClickNextButton.js
onClickProductItem.js
onClickQuantityButtons.js
onClickRequestNowButton.js
onClickRestartButton.js
onClickSubmitButton.js
onInputProductSearch.js
onSubmitForm.js
event-listener.js
methods
addProductToCalculationTable.js
addProductToProductSelection.js
addProductToStorage.js
adjustProductQuantity.js
createProduct.js
deleteProduct.js
elementsVisibility.js
filterVisibility.js
formatPriceToTwoDecimals.js
formatProductPrice.js
getRateTableProductHtml.js
getSelectedProductHtml.js
hideAllProducts.js
hideElement.js
initCurrentState.js
initIndicators.js
initSelectedProducts.js
initSteps.js
showAllProducts.js
showElement.js
successVisibility.js
updateCalculationTableProductPrices.js
updateCalculationTableTotals.js
updateProductQuantityNumbers.js
updateSummary.js
methods.js
storage.js
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}