import Foundation
let pattern = #"([a-z0-9]|(?=[A-Z]))([A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
constants.js
elements.js
event-listener
onClickAddProductButton.js
onClickBackButton.js
onClickCategoryItem.js
onClickDeleteButton.js
onClickFilterByButtons.js
onClickInstallerCheckbox.js
onClickNextButton.js
onClickProductItem.js
onClickQuantityButtons.js
onClickRequestNowButton.js
onClickRestartButton.js
onClickSubmitButton.js
onInputProductSearch.js
onSubmitForm.js
event-listener.js
methods
addProductToCalculationTable.js
addProductToProductSelection.js
addProductToStorage.js
adjustProductQuantity.js
createProduct.js
deleteProduct.js
elementsVisibility.js
filterVisibility.js
formatPriceToTwoDecimals.js
formatProductPrice.js
getRateTableProductHtml.js
getSelectedProductHtml.js
hideAllProducts.js
hideElement.js
initCurrentState.js
initIndicators.js
initSelectedProducts.js
initSteps.js
showAllProducts.js
showElement.js
successVisibility.js
updateCalculationTableProductPrices.js
updateCalculationTableTotals.js
updateProductQuantityNumbers.js
updateSummary.js
methods.js
storage.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)