const regex = /"ABC"/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"ABC"', 'gmi')
const str = `BLABLUB SHSJSKSKDKDNDNDKD ABC dndjmsmdmdmdmdm "ABC"`;
const subst = `"DEF"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);