$re = '/"ABC"/mi';
$str = 'BLABLUB SHSJSKSKDKDNDNDKD ABC dndjmsmdmdmdmdm "ABC"';
$subst = "\"DEF\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;