re = /"ABC"/mi
str = 'BLABLUB SHSJSKSKDKDNDNDKD ABC dndjmsmdmdmdmdm "ABC"'
subst = '"DEF"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result