#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:BE\s?)?[01]?(\d{3}([. ])\d{3}\2\d{3}|\d{9})$"
Local $sString = "BE 0123.321.123" & @CRLF & _
"BE0123.321.123" & @CRLF & _
"BE0123 321 123" & @CRLF & _
"0123.321.123" & @CRLF & _
"123.321.123" & @CRLF & _
"123321123"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)