using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:BE\s?)?[01]?(\d{3}([. ])\d{3}\2\d{3}|\d{9})$";
string substitution = @"$1";
string input = @"BE 0123.321.123
BE0123.321.123
BE0123 321 123
0123.321.123
123.321.123
123321123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}