$re = '/^(?:BE\s?)?[01]?(\d{3}([. ])\d{3}\2\d{3}|\d{9})$/m';
$str = 'BE 0123.321.123
BE0123.321.123
BE0123 321 123
0123.321.123
123.321.123
123321123';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;