const regex = /^(?:BE\s?)?[01]?(\d{3}([. ])\d{3}\2\d{3}|\d{9})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:BE\\s?)?[01]?(\\d{3}([. ])\\d{3}\\2\\d{3}|\\d{9})$', 'gm')
const str = `BE 0123.321.123
BE0123.321.123
BE0123 321 123
0123.321.123
123.321.123
123321123`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);