import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:BE\\s?)?[01]?(\\d{3}([. ])\\d{3}\\2\\d{3}|\\d{9})$";
final String string = "BE 0123.321.123\n"
+ "BE0123.321.123\n"
+ "BE0123 321 123\n"
+ "0123.321.123\n"
+ "123.321.123\n"
+ "123321123";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}