# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[ \t]+|[ \t]+(?=\s)//gm;t' <<< " Bla bla bla blabla bla
blabla
fdfg
"