use strict;
my $str = ' Bla bla bla blabla bla
blabla
fdfg
';
my $regex = qr/^[ \t]+|[ \t]+(?=\s)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";