using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]+|[ \t]+(?=\s)";
string substitution = @"";
string input = @" Bla bla bla blabla bla
blabla
fdfg
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}