const regex = /^[ \t]+|[ \t]+(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\t]+|[ \\t]+(?=\\s)', 'gm')
const str = ` Bla bla bla blabla bla
blabla
fdfg
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);