use strict;
my $str = 'ticket/19
ticket/2/1/19';
my $regex = qr/\/\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";