#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/)?(www\.)?(discord\.gg|(discordapp|discord)\.com\/invite)\/(\w+-?\w+)"
Local $sString = "discord.gg/craftserve" & @CRLF & _
"discord.gg/craftserve-387222965131149313" & @CRLF & _
"discord.com/invite/craftserve" & @CRLF & _
"discord.com/invite/craftserve-387222965131149313" & @CRLF & _
"" & @CRLF & _
"https://discord.gg/craftserve" & @CRLF & _
"https://discord.gg/craftserve-387222965131149313" & @CRLF & _
"https://discord.com/invite/craftserve" & @CRLF & _
"https://discord.com/invite/craftserve-387222965131149313" & @CRLF & _
"" & @CRLF & _
"https://www.discord.gg/craftserve" & @CRLF & _
"https://www.discord.gg/craftserve-387222965131149313" & @CRLF & _
"https://www.discord.com/invite/craftserve" & @CRLF & _
"https://www.discord.com/invite/craftserve-387222965131149313"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")