use strict;
my $str = 'discord.gg/craftserve
discord.gg/craftserve-387222965131149313
discord.com/invite/craftserve
discord.com/invite/craftserve-387222965131149313
https://discord.gg/craftserve
https://discord.gg/craftserve-387222965131149313
https://discord.com/invite/craftserve
https://discord.com/invite/craftserve-387222965131149313
https://www.discord.gg/craftserve
https://www.discord.gg/craftserve-387222965131149313
https://www.discord.com/invite/craftserve
https://www.discord.com/invite/craftserve-387222965131149313';
my $regex = qr/(https?:\/\/)?(www\.)?(discord\.gg|(discordapp|discord)\.com\/invite)\/(\w+-?\w+)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}