import re
regex = re.compile(r"(https?:\/\/)?(www\.)?(discord\.gg|(discordapp|discord)\.com\/invite)\/(\w+-?\w+)", flags=re.IGNORECASE)
test_str = ("discord.gg/craftserve\n"
"discord.gg/craftserve-387222965131149313\n"
"discord.com/invite/craftserve\n"
"discord.com/invite/craftserve-387222965131149313\n\n"
"https://discord.gg/craftserve\n"
"https://discord.gg/craftserve-387222965131149313\n"
"https://discord.com/invite/craftserve\n"
"https://discord.com/invite/craftserve-387222965131149313\n\n"
"https://www.discord.gg/craftserve\n"
"https://www.discord.gg/craftserve-387222965131149313\n"
"https://www.discord.com/invite/craftserve\n"
"https://www.discord.com/invite/craftserve-387222965131149313")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")