using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?(www\.)?(discord\.gg|(discordapp|discord)\.com\/invite)\/(\w+-?\w+)";
string input = @"discord.gg/craftserve
discord.gg/craftserve-387222965131149313
discord.com/invite/craftserve
discord.com/invite/craftserve-387222965131149313
https://discord.gg/craftserve
https://discord.gg/craftserve-387222965131149313
https://discord.com/invite/craftserve
https://discord.com/invite/craftserve-387222965131149313
https://www.discord.gg/craftserve
https://www.discord.gg/craftserve-387222965131149313
https://www.discord.com/invite/craftserve
https://www.discord.com/invite/craftserve-387222965131149313";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}