package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[a-zA-Z']+\b`)
var str = `JÖNAS
Hélton
As kingfishers catch fire, dragonflies draw flame;
As tumbled over rim in roundy wells
Stones ring; like each tucked string tells, each hung bell's
Bow swung finds tongue to fling out broad its name;
Each mortal thing does one thing...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}