re = /\b[a-zA-Z']+\b/
str = 'JÖNAS
Hélton
As kingfishers catch fire, dragonflies draw flame;
As tumbled over rim in roundy wells
Stones ring; like each tucked string tells, each hung bell\'s
Bow swung finds tongue to fling out broad its name;
Each mortal thing does one thing...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end