import re
regex = re.compile(r"\b[a-zA-Z']+\b", flags=re.UNICODE)
test_str = ("JÖNAS\n"
"Hélton\n"
"As kingfishers catch fire, dragonflies draw flame;\n"
"As tumbled over rim in roundy wells\n"
"Stones ring; like each tucked string tells, each hung bell's\n"
"Bow swung finds tongue to fling out broad its name;\n"
"Each mortal thing does one thing...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")