import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[a-zA-Z']+\\b";
final String string = "JÖNAS\n"
+ "Hélton\n"
+ "As kingfishers catch fire, dragonflies draw flame;\n"
+ "As tumbled over rim in roundy wells\n"
+ "Stones ring; like each tucked string tells, each hung bell's\n"
+ "Bow swung finds tongue to fling out broad its name;\n"
+ "Each mortal thing does one thing...";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}