package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/|https:\/\/)((([0-9]\.){4})|[a-z0-9\-_\.][a-z0-9\-_\.]+)(\:)([0-9]{1,5})`)
var str = `http://node.org:443
https://sa.com:1
https://a:31
123.123.123.123:231
http://213.123.123.122:231`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}