import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/|https:\\/\\/)((([0-9]\\.){4})|[a-z0-9\\-_\\.][a-z0-9\\-_\\.]+)(\\:)([0-9]{1,5})";
final String string = "http://node.org:443\n"
+ "https://sa.com:1\n"
+ "https://a:31\n"
+ "123.123.123.123:231\n"
+ "http://213.123.123.122:231";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}