// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http:\/\/|https:\/\/)((([0-9]\.){4})|[a-z0-9\-_\.][a-z0-9\-_\.]+)(\:)([0-9]{1,5})").unwrap();
let string = "http://node.org:443
https://sa.com:1
https://a:31
123.123.123.123:231
http://213.123.123.122:231";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}