const regex = /(http:\/\/|https:\/\/)((([0-9]\.){4})|[a-z0-9\-_\.][a-z0-9\-_\.]+)(\:)([0-9]{1,5})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:\\\/\\\/|https:\\\/\\\/)((([0-9]\\.){4})|[a-z0-9\\-_\\.][a-z0-9\\-_\\.]+)(\\:)([0-9]{1,5})', 'g')
const str = `http://node.org:443
https://sa.com:1
https://a:31
123.123.123.123:231
http://213.123.123.122:231`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}