using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z0-9\\\/_\-]|([A-Za-z0-9\\\/_\-][A-Za-z0-9\\\/_\- ]{0,18}[A-Za-z0-9\\\/_\-]))$";
string input = @"kkdkd df sdf lk aj33
12345678901234567890
kjlf l-Ka034-/\_ kj0
adsfdsafsdaf dsfsdfa
dlASjd83_-/\dfdsfsda
adsfsdas sdafsdafsa
73jkjdfKJH_/\-_saf97
dsfsdf
2
11
111
- dsf
-df
/dsaf
\asdf
_asdf
_ sdfjlksdaflk jasdf
adsfsdas sdafsdafs#
adsfsdafsdfsdfsadds
dddddddfsdafljkasdd
$
123456789012345678901
asdf
2
2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}