# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Za-z0-9\\\/_\-]|([A-Za-z0-9\\\/_\-][A-Za-z0-9\\\/_\- ]{0,18}[A-Za-z0-9\\\/_\-]))$"
test_str = ("kkdkd df sdf lk aj33\n"
"12345678901234567890\n"
"kjlf l-Ka034-/\\_ kj0\n"
"adsfdsafsdaf dsfsdfa\n"
"dlASjd83_-/\\dfdsfsda\n"
"adsfsdas sdafsdafsa\n"
"73jkjdfKJH_/\\-_saf97\n"
"dsfsdf\n"
"2\n"
"11\n"
"111\n"
"- dsf\n"
"-df\n"
"/dsaf\n"
"\\asdf\n"
"_asdf\n"
"_ sdfjlksdaflk jasdf\n"
"adsfsdas sdafsdafs#\n"
" adsfsdafsdfsdfsadds\n"
"dddddddfsdafljkasdd \n"
"$\n"
"123456789012345678901\n"
" asdf\n"
" \n"
"2 \n"
" 2\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.