const regex = /^([A-Za-z0-9\\\/_\-]|([A-Za-z0-9\\\/_\-][A-Za-z0-9\\\/_\- ]{0,18}[A-Za-z0-9\\\/_\-]))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z0-9\\\\\\\/_\\-]|([A-Za-z0-9\\\\\\\/_\\-][A-Za-z0-9\\\\\\\/_\\- ]{0,18}[A-Za-z0-9\\\\\\\/_\\-]))$', 'gm')
const str = `kkdkd df sdf lk aj33
12345678901234567890
kjlf l-Ka034-/\\_ kj0
adsfdsafsdaf dsfsdfa
dlASjd83_-/\\dfdsfsda
adsfsdas sdafsdafsa
73jkjdfKJH_/\\-_saf97
dsfsdf
2
11
111
- dsf
-df
/dsaf
\\asdf
_asdf
_ sdfjlksdaflk jasdf
adsfsdas sdafsdafs#
adsfsdafsdfsdfsadds
dddddddfsdafljkasdd
\$
123456789012345678901
asdf
2
2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}