// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z0-9\\\/_\-]|([A-Za-z0-9\\\/_\-][A-Za-z0-9\\\/_\- ]{0,18}[A-Za-z0-9\\\/_\-]))$").unwrap();
let string = "kkdkd df sdf lk aj33
12345678901234567890
kjlf l-Ka034-/\\_ kj0
adsfdsafsdaf dsfsdfa
dlASjd83_-/\\dfdsfsda
adsfsdas sdafsdafsa
73jkjdfKJH_/\\-_saf97
dsfsdf
2
11
111
- dsf
-df
/dsaf
\\asdf
_asdf
_ sdfjlksdaflk jasdf
adsfsdas sdafsdafs#
adsfsdafsdfsdfsadds
dddddddfsdafljkasdd
$
123456789012345678901
asdf
2
2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}