import Foundation
let pattern = #"^([A-Za-z0-9\\\/_\-]|([A-Za-z0-9\\\/_\-][A-Za-z0-9\\\/_\- ]{0,18}[A-Za-z0-9\\\/_\-]))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
kkdkd df sdf lk aj33
12345678901234567890
kjlf l-Ka034-/\_ kj0
adsfdsafsdaf dsfsdfa
dlASjd83_-/\dfdsfsda
adsfsdas sdafsdafsa
73jkjdfKJH_/\-_saf97
dsfsdf
2
11
111
- dsf
-df
/dsaf
\asdf
_asdf
_ sdfjlksdaflk jasdf
adsfsdas sdafsdafs#
adsfsdafsdfsdfsadds
dddddddfsdafljkasdd
$
123456789012345678901
asdf
2
2
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)