using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(?=({\w+(?1)?})$)|\G(?!\A)){(\w+)";
string input = @"{pppppp
{a}
{a{b}}
{a{b{c}}}
{a{b{c{d}}}}
{a{bb{ccc{dd}}}}
a
{{a}
{a}}
{a}b
z{a{b}}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}