import re
regex = re.compile(r"(?:^(?=({\w+(?1)?})$)|\G(?!\A)){(\w+)", flags=re.MULTILINE)
test_str = ("{pppppp\n"
"{a}\n"
"{a{b}}\n"
"{a{b{c}}}\n"
"{a{b{c{d}}}}\n"
"{a{bb{ccc{dd}}}}\n\n"
"a\n"
"{{a}\n"
"{a}}\n"
"{a}b\n"
"z{a{b}}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")